---
name: "ldns_key_rr2ds"
section: "3"
platform: "linux"
package: "ldns"
version: "1.9.2-1"
release: "Arch Linux 2026-11-01"
platforms: ["linux"]
url: "https://new.carta.tech/ldns_key_rr2ds"
---

# ldns\_key\_rr2ds(3)

create DS rr from DNSKEY rr

## NAME

ldns\_key\_rr2ds - create DS rr from DNSKEY rr

## SYNOPSIS

\#include \<stdint.h\>\
 \#include \<stdbool.h\>\

\#include \<ldns/ldns.h\>

ldns\_rr\* ldns\_key\_rr2ds(const ldns\_rr \*key, ldns\_hash h);

## DESCRIPTION

*ldns\_key\_rr2ds*() returns a new DS rr that represents the given key rr.

.br **\*key**: the key to convert .br **h**: the hash to use LDNS\_SHA1/LDNS\_SHA256

.br Returns ldns\_rr\* a new rr pointer to a DS

## AUTHOR

The ldns team at NLnet Labs.

## REPORTING BUGS

Please report bugs to dns-team@nlnetlabs.nl or on GitHub at https://github.com/NLnetLabs/ldns/issues

## COPYRIGHT

Copyright (c) 2004 - 2006 NLnet Labs.

Licensed under the BSD License. There is NO warranty; not even for MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE.

## SEE ALSO

*ldns\_key*. And **perldoc Net::DNS**, **RFC1034**, **RFC1035**, **RFC4033**, **RFC4034**  and **RFC4035**.

## REMARKS

This manpage was automatically generated from the ldns source code.
