---
name: "ldns_key_list_push_key"
section: "3"
platform: "linux"
package: "ldns"
version: "1.9.2-1"
release: "Arch Linux 2026-11-01"
platforms: ["linux"]
url: "https://new.carta.tech/ldns_key_list_push_key"
---

# ldns\_key\_list\_push\_key(3)

manipulate ldns\_key\_list

## NAME

ldns\_key\_list\_push\_key, ldns\_key\_list\_pop\_key - manipulate ldns\_key\_list

## SYNOPSIS

\#include \<stdint.h\>\
 \#include \<stdbool.h\>\

\#include \<ldns/ldns.h\>

bool ldns\_key\_list\_push\_key(ldns\_key\_list \*key\_list, ldns\_key \*key);

ldns\_key\* ldns\_key\_list\_pop\_key(ldns\_key\_list \*key\_list);

## DESCRIPTION

*ldns\_key\_list\_push\_key*() pushes a key to a keylist .br **key\_list**: the key\_list to push to  .br **key**: the key to push  .br Returns false on error, otherwise true

*ldns\_key\_list\_pop\_key*() pops the last rr from a keylist .br **key\_list**: the rr\_list to pop from .br Returns NULL if nothing to pop. Otherwise the popped RR

## AUTHOR

The ldns team at NLnet Labs.

## REPORTING BUGS

Please report bugs to dns-team@nlnetlabs.nl or on GitHub at https://github.com/NLnetLabs/ldns/issues

## COPYRIGHT

Copyright (c) 2004 - 2006 NLnet Labs.

Licensed under the BSD License. There is NO warranty; not even for MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE.

## SEE ALSO

*ldns\_key*. And **perldoc Net::DNS**, **RFC1034**, **RFC1035**, **RFC4033**, **RFC4034**  and **RFC4035**.

## REMARKS

This manpage was automatically generated from the ldns source code.
