---
name: "ldns_key_free"
section: "3"
platform: "linux"
package: "ldns"
version: "1.9.2-1"
release: "Arch Linux 2026-11-01"
platforms: ["linux"]
url: "https://new.carta.tech/ldns_key_free"
---

# ldns\_key\_free(3)

free a ldns\_key

## NAME

ldns\_key\_free, ldns\_key\_deep\_free, ldns\_key\_list\_free - free a ldns\_key

## SYNOPSIS

\#include \<stdint.h\>\
 \#include \<stdbool.h\>\

\#include \<ldns/ldns.h\>

void ldns\_key\_free(ldns\_key \*key);

void ldns\_key\_deep\_free(ldns\_key \*key);

void ldns\_key\_list\_free(ldns\_key\_list \*key\_list);

## DESCRIPTION

*ldns\_key\_free*() frees a key structure, but not its internal data structures

.br **key**: the key object to free

*ldns\_key\_deep\_free*() frees a key structure and all its internal data structures, except the data set by ldns\_key\_set\_external\_key()

.br **key**: the key object to free

*ldns\_key\_list\_free*() Frees a key list structure .br **key\_list**: the key list object to free

## AUTHOR

The ldns team at NLnet Labs.

## REPORTING BUGS

Please report bugs to dns-team@nlnetlabs.nl or on GitHub at https://github.com/NLnetLabs/ldns/issues

## COPYRIGHT

Copyright (c) 2004 - 2006 NLnet Labs.

Licensed under the BSD License. There is NO warranty; not even for MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE.

## SEE ALSO

*ldns\_key*. And **perldoc Net::DNS**, **RFC1034**, **RFC1035**, **RFC4033**, **RFC4034**  and **RFC4035**.

## REMARKS

This manpage was automatically generated from the ldns source code.
