---
name: "ldns_key2rr"
section: "3"
platform: "linux"
package: "ldns"
version: "1.9.2-1"
release: "Arch Linux 2026-11-01"
platforms: ["linux"]
url: "https://new.carta.tech/ldns_key2rr"
---

# ldns\_key2rr(3)

convert ldns\_key to rr

## NAME

ldns\_key2rr - convert ldns\_key to rr

## SYNOPSIS

\#include \<stdint.h\>\
 \#include \<stdbool.h\>\

\#include \<ldns/ldns.h\>

ldns\_rr\* ldns\_key2rr(const ldns\_key \*k);

## DESCRIPTION

*ldns\_key2rr*() converts a ldns\_key to a public key rr If the key data exists at an external point, the corresponding rdata field must still be added with ldns\_rr\_rdf\_push() to the result rr of this function

.br **k**: the ldns\_key to convert .br Returns ldns\_rr representation of the key

## AUTHOR

The ldns team at NLnet Labs.

## REPORTING BUGS

Please report bugs to dns-team@nlnetlabs.nl or on GitHub at https://github.com/NLnetLabs/ldns/issues

## COPYRIGHT

Copyright (c) 2004 - 2006 NLnet Labs.

Licensed under the BSD License. There is NO warranty; not even for MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE.

## SEE ALSO

*ldns\_key*. And **perldoc Net::DNS**, **RFC1034**, **RFC1035**, **RFC4033**, **RFC4034**  and **RFC4035**.

## REMARKS

This manpage was automatically generated from the ldns source code.
