---
name: "ldns_key"
section: "3"
platform: "linux"
package: "ldns"
version: "1.9.2-1"
release: "Arch Linux 2026-11-01"
platforms: ["linux"]
url: "https://new.carta.tech/ldns_key"
---

# ldns\_key(3)

ldns\_key data structure

## NAME

ldns\_key - ldns\_key data structure

## SYNOPSIS

\#include \<stdint.h\>\
 \#include \<stdbool.h\>\

\#include \<ldns/ldns.h\>

 ldns\_key();

## DESCRIPTION

*ldns\_key*()

## AUTHOR

The ldns team at NLnet Labs.

## REPORTING BUGS

Please report bugs to dns-team@nlnetlabs.nl or on GitHub at https://github.com/NLnetLabs/ldns/issues

## COPYRIGHT

Copyright (c) 2004 - 2006 NLnet Labs.

Licensed under the BSD License. There is NO warranty; not even for MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE.

## SEE ALSO

*ldns\_key\_new*, *ldns\_key\_new\_frm\_algorithm*, *ldns\_key\_new\_frm\_fp*, *ldns\_key\_new\_frm\_fp\_l*, *ldns\_key\_new\_frm\_fp\_rsa*, *ldns\_key\_new\_frm\_fp\_rsa\_l*, *ldns\_key\_new\_frm\_fp\_dsa*, *ldns\_key\_new\_frm\_fp\_dsa\_l*, *ldns\_key\_list\_new*, *ldns\_key\_set\_algorithm*, *ldns\_key\_set\_rsa\_key*, *ldns\_key\_set\_dsa\_key*, *ldns\_key\_set\_hmac\_key*, *ldns\_key\_set\_origttl*, *ldns\_key\_set\_inception*, *ldns\_key\_set\_expiration*, *ldns\_key\_set\_pubkey\_owner*, *ldns\_key\_set\_keytag*, *ldns\_key\_set\_flags*, *ldns\_key\_list\_set\_key\_count*, *ldns\_key\_list\_push\_key*, *ldns\_key\_list\_pop\_key*, *ldns\_key\_list\_key\_count*, *ldns\_key\_list\_key*, *ldns\_key\_rsa\_key*, *ldns\_key\_dsa\_key*, *ldns\_key\_algorithm*, *ldns\_key\_hmac\_key*, *ldns\_key\_origttl*, *ldns\_key\_inception*, *ldns\_key\_expiration*, *ldns\_key\_keytag*, *ldns\_key\_pubkey\_owner*, *ldns\_key\_flags*, *ldns\_key2rr*, *ldns\_key\_free*, *ldns\_key\_deep\_free*, *ldns\_key\_list\_free*, *ldns\_key\_print*. And **perldoc Net::DNS**, **RFC1034**, **RFC1035**, **RFC4033**, **RFC4034**  and **RFC4035**.

## REMARKS

This manpage was automatically generated from the ldns source code.
