---
name: "ldns_get_rr_list_addr_by_name"
section: "3"
platform: "linux"
package: "ldns"
version: "1.9.2-1"
release: "Arch Linux 2026-11-01"
platforms: ["linux"]
url: "https://new.carta.tech/ldns_get_rr_list_addr_by_name"
---

# ldns\_get\_rr\_list\_addr\_by\_name(3)

get addresses by name or names by address

## NAME

ldns\_get\_rr\_list\_addr\_by\_name, ldns\_get\_rr\_list\_name\_by\_addr - get addresses by name or names by address

## SYNOPSIS

\#include \<stdint.h\>\
 \#include \<stdbool.h\>\

\#include \<ldns/ldns.h\>

ldns\_rr\_list\* ldns\_get\_rr\_list\_addr\_by\_name(ldns\_resolver \*r, const ldns\_rdf \*name, ldns\_rr\_class c, uint16\_t flags);

ldns\_rr\_list\* ldns\_get\_rr\_list\_name\_by\_addr(ldns\_resolver \*r, const ldns\_rdf \*addr, ldns\_rr\_class c, uint16\_t flags);

## DESCRIPTION

*ldns\_get\_rr\_list\_addr\_by\_name*() Ask the resolver about name and return all address records .br **r**: the resolver to use .br **name**: the name to look for .br **c**: the class to use .br **flags**: give some optional flags to the query

*ldns\_get\_rr\_list\_name\_by\_addr*() ask the resolver about the address and return the name .br **r**: the resolver to use .br **addr**: the addr to look for .br **c**: the class to use .br **flags**: give some optional flags to the query

## AUTHOR

The ldns team at NLnet Labs.

## REPORTING BUGS

Please report bugs to dns-team@nlnetlabs.nl or on GitHub at https://github.com/NLnetLabs/ldns/issues

## COPYRIGHT

Copyright (c) 2004 - 2006 NLnet Labs.

Licensed under the BSD License. There is NO warranty; not even for MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE.

## SEE ALSO

*ldns\_rr\_list*, *ldns\_rr*. And **perldoc Net::DNS**, **RFC1034**, **RFC1035**, **RFC4033**, **RFC4034**  and **RFC4035**.

## REMARKS

This manpage was automatically generated from the ldns source code.
