---
name: "ldns_get_rr_class_by_name"
section: "3"
platform: "linux"
package: "ldns"
version: "1.9.2-1"
release: "Arch Linux 2026-11-01"
platforms: ["linux"]
url: "https://new.carta.tech/ldns_get_rr_class_by_name"
---

# ldns\_get\_rr\_class\_by\_name(3)

lookup class or type by name

## NAME

ldns\_get\_rr\_class\_by\_name, ldns\_get\_rr\_type\_by\_name - lookup class or type by name

## SYNOPSIS

\#include \<stdint.h\>\
 \#include \<stdbool.h\>\

\#include \<ldns/ldns.h\>

ldns\_rr\_class ldns\_get\_rr\_class\_by\_name(const char \*name);

ldns\_rr\_type ldns\_get\_rr\_type\_by\_name(const char \*name);

## DESCRIPTION

*ldns\_get\_rr\_class\_by\_name*() retrieves a class by looking up its name. .br **name**: string with the name .br Returns the cass which corresponds with the name

*ldns\_get\_rr\_type\_by\_name*() retrieves a rrtype by looking up its name. .br **name**: a string with the name .br Returns the type which corresponds with the name

## AUTHOR

The ldns team at NLnet Labs.

## REPORTING BUGS

Please report bugs to dns-team@nlnetlabs.nl or on GitHub at https://github.com/NLnetLabs/ldns/issues

## COPYRIGHT

Copyright (c) 2004 - 2006 NLnet Labs.

Licensed under the BSD License. There is NO warranty; not even for MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE.

## SEE ALSO

*ldns\_rr*, *ldns\_rr\_list*. And **perldoc Net::DNS**, **RFC1034**, **RFC1035**, **RFC4033**, **RFC4034**  and **RFC4035**.

## REMARKS

This manpage was automatically generated from the ldns source code.
