---
name: "ldns_fget_token"
section: "3"
platform: "linux"
package: "ldns"
version: "1.9.2-1"
release: "Arch Linux 2026-11-01"
platforms: ["linux"]
url: "https://new.carta.tech/ldns_fget_token"
---

# ldns\_fget\_token(3)

get tokens from files

## NAME

ldns\_fget\_token, ldns\_fskipcs - get tokens from files

## SYNOPSIS

\#include \<stdint.h\>\
 \#include \<stdbool.h\>\

\#include \<ldns/ldns.h\>

ssize\_t ldns\_fget\_token(FILE \*f, char \*token, const char \*delim, size\_t limit);

void ldns\_fskipcs(FILE \*fp, const char \*s);

## DESCRIPTION

*ldns\_fget\_token*() returns a token/char from the stream F. This function deals with ( and ) in the stream, and ignores them when encountered .br **\*f**: the file to read from .br **\*token**: the read token is put here .br **\*delim**: chars at which the parsing should stop .br **\*limit**: how much to read. If 0 the builtin maximum is used .br Returns 0 on error of EOF of the stream F.  Otherwise return the length of what is read

*ldns\_fskipcs*() skips all of the characters in the given string in the fp, moving the position to the first character that is not in \*s. .br **\*fp**: file to use .br **\*s**: characters to skip .br Returns void

## AUTHOR

The ldns team at NLnet Labs.

## REPORTING BUGS

Please report bugs to dns-team@nlnetlabs.nl or on GitHub at https://github.com/NLnetLabs/ldns/issues

## COPYRIGHT

Copyright (c) 2004 - 2006 NLnet Labs.

Licensed under the BSD License. There is NO warranty; not even for MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE.

## SEE ALSO

*ldns\_buffer*. And **perldoc Net::DNS**, **RFC1034**, **RFC1035**, **RFC4033**, **RFC4034**  and **RFC4035**.

## REMARKS

This manpage was automatically generated from the ldns source code.
