---
name: "ldns_duration_create"
section: "3"
platform: "linux"
package: "ldns"
version: "1.9.2-1"
release: "Arch Linux 2026-11-01"
platforms: ["linux"]
url: "https://new.carta.tech/ldns_duration_create"
---

# ldns\_duration\_create(3)

duration type and related functions

## NAME

ldns\_duration\_type, ldns\_duration\_create, ldns\_duration\_create\_from\_string, ldns\_duration\_cleanup, ldns\_duration\_compare, ldns\_duration2string, ldns\_duration2time - duration type and related functions

## SYNOPSIS

\#include \<stdint.h\>\
 \#include \<stdbool.h\>\

\#include \<ldns/ldns.h\>

ldns\_duration\_type\* ldns\_duration\_create(void);

ldns\_duration\_type\* ldns\_duration\_create\_from\_string(const char\* str);

void ldns\_duration\_cleanup(ldns\_duration\_type\* duration);

int ldns\_duration\_compare(const ldns\_duration\_type\* d1, const ldns\_duration\_type\* d2);

char\* ldns\_duration2string(const ldns\_duration\_type\* duration);

time\_t ldns\_duration2time(const ldns\_duration\_type\* duration);

## DESCRIPTION

*ldns\_duration\_type*\
 Duration.\

struct ldns\_duration\_struct\
 {\
\
     time\_t years;\
\
     time\_t months;\
\
     time\_t weeks;\
\
     time\_t days;\
\
     time\_t hours;\
\
     time\_t minutes;\
\
     time\_t seconds;\
 };\

typedef struct ldns\_duration\_struct ldns\_duration\_type;

*ldns\_duration\_create*() Create a new 'instant' duration. .br Returns ldns\_duration\_type\* created duration

*ldns\_duration\_create\_from\_string*() Create a duration from string. .br **str**: string-format duration .br Returns ldns\_duration\_type\* created duration

*ldns\_duration\_cleanup*() Clean up duration. .br **duration**: duration to be cleaned up

*ldns\_duration\_compare*() Compare durations. .br **d1**: one duration .br **d2**: another duration .br Returns int 0 if equal, -1 if d1 \< d2, 1 if d2 \< d1

*ldns\_duration2string*() Convert a duration to a string. .br **duration**: duration to be converted .br Returns char\* string-format duration

*ldns\_duration2time*() Convert a duration to a time. .br **duration**: duration to be converted .br Returns time\_t time-format duration

## AUTHOR

The ldns team at NLnet Labs.

## REPORTING BUGS

Please report bugs to dns-team@nlnetlabs.nl or on GitHub at https://github.com/NLnetLabs/ldns/issues

## COPYRIGHT

Copyright (c) 2004 - 2006 NLnet Labs.

Licensed under the BSD License. There is NO warranty; not even for MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE.

## SEE ALSO

**perldoc Net::DNS**, **RFC1034**, **RFC1035**, **RFC4033**, **RFC4034** and **RFC4035**.

## REMARKS

This manpage was automatically generated from the ldns source code.
