---
name: "ldns_dnssec_verify_denial"
section: "3"
platform: "linux"
package: "ldns"
version: "1.9.2-1"
release: "Arch Linux 2026-11-01"
platforms: ["linux"]
url: "https://new.carta.tech/ldns_dnssec_verify_denial"
---

# ldns\_dnssec\_verify\_denial(3)

verify denial of existence

## NAME

ldns\_dnssec\_verify\_denial, ldns\_dnssec\_verify\_denial\_nsec3 - verify denial of existence

## SYNOPSIS

\#include \<stdint.h\>\
 \#include \<stdbool.h\>\

\#include \<ldns/ldns.h\>

ldns\_status ldns\_dnssec\_verify\_denial(ldns\_rr \*rr, ldns\_rr\_list \*nsecs, ldns\_rr\_list \*rrsigs);

ldns\_status ldns\_dnssec\_verify\_denial\_nsec3(ldns\_rr \*rr, ldns\_rr\_list \*nsecs, ldns\_rr\_list \*rrsigs, ldns\_pkt\_rcode packet\_rcode, ldns\_rr\_type packet\_qtype, bool packet\_nodata);

## DESCRIPTION

*ldns\_dnssec\_verify\_denial*() denial is not just a river in egypt

.br **rr**: The (query) RR to check the denial of existence for .br **nsecs**: The list of NSEC RRs that are supposed to deny the existence of the RR .br **rrsigs**: The RRSIG RR covering the NSEC RRs .br Returns LDNS\_STATUS\_OK if the NSEC RRs deny the existence, error code containing the reason they do not otherwise

*ldns\_dnssec\_verify\_denial\_nsec3*() Denial of existence using NSEC3 records Since NSEC3 is a bit more complicated than normal denial, some context arguments are needed

.br **rr**: The (query) RR to check the denial of existence for .br **nsecs**: The list of NSEC3 RRs that are supposed to deny the existence of the RR .br **rrsigs**: The RRSIG rr covering the NSEC RRs .br **packet\_rcode**: The RCODE value of the packet that provided the NSEC3 RRs .br **packet\_qtype**: The original query RR type .br **packet\_nodata**: True if the providing packet had an empty ANSWER section .br Returns LDNS\_STATUS\_OK if the NSEC3 RRs deny the existence, error code containing the reason they do not otherwise

## AUTHOR

The ldns team at NLnet Labs.

## REPORTING BUGS

Please report bugs to dns-team@nlnetlabs.nl or on GitHub at https://github.com/NLnetLabs/ldns/issues

## COPYRIGHT

Copyright (c) 2004 - 2006 NLnet Labs.

Licensed under the BSD License. There is NO warranty; not even for MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE.

## SEE ALSO

*ldns\_dnssec\_trust\_tree*, *ldns\_dnssec\_data\_chain*. And **perldoc Net::DNS**, **RFC1034**, **RFC1035**, **RFC4033**, **RFC4034**  and **RFC4035**.

## REMARKS

This manpage was automatically generated from the ldns source code.
