---
name: "ldns_dnssec_rrsets_type"
section: "3"
platform: "linux"
package: "ldns"
version: "1.9.2-1"
release: "Arch Linux 2026-11-01"
platforms: ["linux"]
url: "https://new.carta.tech/ldns_dnssec_rrsets_type"
---

# ldns\_dnssec\_rrsets\_type(3)

functions for ldns\_dnssec\_rrsets

## NAME

ldns\_dnssec\_rrsets\_new, ldns\_dnssec\_rrsets\_free, ldns\_dnssec\_rrsets\_type, ldns\_dnssec\_rrsets\_set\_type, ldns\_dnssec\_rrsets\_add\_rr, ldns\_dnssec\_rrsets\_print - functions for ldns\_dnssec\_rrsets

## SYNOPSIS

\#include \<stdint.h\>\
 \#include \<stdbool.h\>\

\#include \<ldns/ldns.h\>

ldns\_dnssec\_rrsets\* ldns\_dnssec\_rrsets\_new(void);

void ldns\_dnssec\_rrsets\_free(ldns\_dnssec\_rrsets \*rrsets);

ldns\_rr\_type ldns\_dnssec\_rrsets\_type(const ldns\_dnssec\_rrsets \*rrsets);

ldns\_status ldns\_dnssec\_rrsets\_set\_type(ldns\_dnssec\_rrsets \*rrsets, ldns\_rr\_type type);

ldns\_status ldns\_dnssec\_rrsets\_add\_rr(ldns\_dnssec\_rrsets \*rrsets, ldns\_rr \*rr);

void ldns\_dnssec\_rrsets\_print(FILE \*out, const ldns\_dnssec\_rrsets \*rrsets, bool follow);

## DESCRIPTION

*ldns\_dnssec\_rrsets\_new*() Creates a new list (entry) of RRsets .br Returns the newly allocated structure

*ldns\_dnssec\_rrsets\_free*() Frees the list of rrsets and their rrs, but \*not\* the ldns\_rr records in the sets

.br **rrsets**: the data structure to free

*ldns\_dnssec\_rrsets\_type*() Returns the rr type of the rrset (that is head of the given list)

.br **rrsets**: the rrset to get the type of .br Returns the rr type

*ldns\_dnssec\_rrsets\_set\_type*() Sets the RR type of the rrset (that is head of the given list)

.br **rrsets**: the rrset to set the type of .br **type**: the type to set .br Returns LDNS\_STATUS\_OK on success

*ldns\_dnssec\_rrsets\_add\_rr*() Add an ldns\_rr to the corresponding RRset in the given list of RRsets. If it is not present, add it as a new RRset with 1 record.

.br **rrsets**: the list of rrsets to add the RR to .br **rr**: the rr to add to the list of rrsets .br Returns LDNS\_STATUS\_OK on success and LDNS\_STATUS\_EQUAL\_ERR when and RR with equal ownername, class, type and rdata already exists.

*ldns\_dnssec\_rrsets\_print*() Print the given list of rrsets to the given file descriptor

.br **out**: the file descriptor to print to .br **rrsets**: the list of RRsets to print .br **follow**: if set to false, only print the first RRset

## AUTHOR

The ldns team at NLnet Labs.

## REPORTING BUGS

Please report bugs to dns-team@nlnetlabs.nl or on GitHub at https://github.com/NLnetLabs/ldns/issues

## COPYRIGHT

Copyright (c) 2004 - 2006 NLnet Labs.

Licensed under the BSD License. There is NO warranty; not even for MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE.

## SEE ALSO

*ldns\_dnssec\_zone*. And **perldoc Net::DNS**, **RFC1034**, **RFC1035**, **RFC4033**, **RFC4034**  and **RFC4035**.

## REMARKS

This manpage was automatically generated from the ldns source code.
