---
name: "ldns_dnssec_data_chain_free"
section: "3"
platform: "linux"
package: "ldns"
version: "1.9.2-1"
release: "Arch Linux 2026-11-01"
platforms: ["linux"]
url: "https://new.carta.tech/ldns_dnssec_data_chain_free"
---

# ldns\_dnssec\_data\_chain\_free(3)

ldns\_chain creation, destruction and printing

## NAME

ldns\_dnssec\_data\_chain\_new, ldns\_dnssec\_data\_chain\_free, ldns\_dnssec\_data\_chain\_deep\_free, ldns\_dnssec\_build\_data\_chain, ldns\_dnssec\_data\_chain\_print - ldns\_chain creation, destruction and printing

## SYNOPSIS

\#include \<stdint.h\>\
 \#include \<stdbool.h\>\

\#include \<ldns/ldns.h\>

ldns\_dnssec\_data\_chain\* ldns\_dnssec\_data\_chain\_new(void);

void ldns\_dnssec\_data\_chain\_free(ldns\_dnssec\_data\_chain \*chain);

void ldns\_dnssec\_data\_chain\_deep\_free(ldns\_dnssec\_data\_chain \*chain);

ldns\_dnssec\_data\_chain\* ldns\_dnssec\_build\_data\_chain(ldns\_resolver \*res, const uint16\_t qflags, const ldns\_rr\_list \*data\_set, const ldns\_pkt \*pkt, ldns\_rr \*orig\_rr);

void ldns\_dnssec\_data\_chain\_print(FILE \*out, const ldns\_dnssec\_data\_chain \*chain);

## DESCRIPTION

*ldns\_dnssec\_data\_chain\_new*() Creates a new dnssec\_chain structure .br Returns ldns\_dnssec\_data\_chain \*

*ldns\_dnssec\_data\_chain\_free*() Frees a dnssec\_data\_chain structure

.br **\*chain**: The chain to free

*ldns\_dnssec\_data\_chain\_deep\_free*() Frees a dnssec\_data\_chain structure, and all data contained therein

.br **\*chain**: The dnssec\_data\_chain to free

*ldns\_dnssec\_build\_data\_chain*() Build an ldns\_dnssec\_data\_chain, which contains all DNSSEC data that is needed to derive the trust tree later

The data\_set will be cloned

.br **\*res**: resolver structure for further needed queries .br **qflags**: resolution flags .br **\*data\_set**: The original rrset where the chain ends .br **\*pkt**: optional, can contain the original packet (and hence the sigs and maybe the key) .br **\*orig\_rr**: The original Resource Record

.br Returns the DNSSEC data chain

*ldns\_dnssec\_data\_chain\_print*() Prints the dnssec\_data\_chain to the given file stream

.br **\*out**: The file stream to print to .br **\*chain**: The dnssec\_data\_chain to print

## AUTHOR

The ldns team at NLnet Labs.

## REPORTING BUGS

Please report bugs to dns-team@nlnetlabs.nl or on GitHub at https://github.com/NLnetLabs/ldns/issues

## COPYRIGHT

Copyright (c) 2004 - 2006 NLnet Labs.

Licensed under the BSD License. There is NO warranty; not even for MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE.

## SEE ALSO

*ldns\_dnssec\_data\_chain*. And **perldoc Net::DNS**, **RFC1034**, **RFC1035**, **RFC4033**, **RFC4034**  and **RFC4035**.

## REMARKS

This manpage was automatically generated from the ldns source code.
