---
name: "ldns_dname_str_absolute"
section: "3"
platform: "linux"
package: "ldns"
version: "1.9.2-1"
release: "Arch Linux 2026-11-01"
platforms: ["linux"]
url: "https://new.carta.tech/ldns_dname_str_absolute"
---

# ldns\_dname\_str\_absolute(3)

check properties of dnames

## NAME

ldns\_dname\_is\_subdomain, ldns\_dname\_str\_absolute, ldns\_dname\_label - check properties of dnames

## SYNOPSIS

\#include \<stdint.h\>\
 \#include \<stdbool.h\>\

\#include \<ldns/ldns.h\>

bool ldns\_dname\_is\_subdomain(const ldns\_rdf \*sub, const ldns\_rdf \*parent);

bool ldns\_dname\_str\_absolute(const char \*dname\_str);

ldns\_rdf \* ldns\_dname\_label(const ldns\_rdf \*rdf, uint8\_t labelpos);

## DESCRIPTION

*ldns\_dname\_is\_subdomain*() test whether the name sub falls under parent (i.e. is a subdomain of parent). This function will return false if the given dnames are equal. .br **sub**: the name to test .br **parent**: the parent's name .br Returns true if sub falls under parent, otherwise false

*ldns\_dname\_str\_absolute*() Checks whether the given dname string is absolute (i.e. ends with a '.') .br **\*dname\_str**: a string representing the dname .br Returns true or false

*ldns\_dname\_label*() look inside the rdf and if it is an LDNS\_RDF\_TYPE\_DNAME try and retrieve a specific label. The labels are numbered starting from 0 (left most). .br **rdf**: the rdf to look in .br **labelpos**: return the label with this number .br Returns a ldns\_rdf\* with the label as name or NULL on error

## AUTHOR

The ldns team at NLnet Labs.

## REPORTING BUGS

Please report bugs to dns-team@nlnetlabs.nl or on GitHub at https://github.com/NLnetLabs/ldns/issues

## COPYRIGHT

Copyright (c) 2004 - 2006 NLnet Labs.

Licensed under the BSD License. There is NO warranty; not even for MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE.

## SEE ALSO

**perldoc Net::DNS**, **RFC1034**, **RFC1035**, **RFC4033**, **RFC4034** and **RFC4035**.

## REMARKS

This manpage was automatically generated from the ldns source code.
