---
name: "ldns_dname_label_count"
section: "3"
platform: "linux"
package: "ldns"
version: "1.9.2-1"
release: "Arch Linux 2026-11-01"
platforms: ["linux"]
url: "https://new.carta.tech/ldns_dname_label_count"
---

# ldns\_dname\_label\_count(3)

dname label functions

## NAME

ldns\_dname\_left\_chop, ldns\_dname\_label\_count - dname label functions

## SYNOPSIS

\#include \<stdint.h\>\
 \#include \<stdbool.h\>\

\#include \<ldns/ldns.h\>

ldns\_rdf\* ldns\_dname\_left\_chop(const ldns\_rdf \*d);

uint8\_t ldns\_dname\_label\_count(const ldns\_rdf \*r);

## DESCRIPTION

*ldns\_dname\_left\_chop*() chop one label off the left side of a dname. so wwww.nlnetlabs.nl, becomes nlnetlabs.nl This new name is a clone and must be freed with ldns\_deep\_free() .br **d**: the dname to chop .br Returns the remaining dname

*ldns\_dname\_label\_count*() count the number of labels inside a LDNS\_RDF\_DNAME type rdf. .br **\*r**: the rdf .br Returns the number of labels

## AUTHOR

The ldns team at NLnet Labs.

## REPORTING BUGS

Please report bugs to dns-team@nlnetlabs.nl or on GitHub at https://github.com/NLnetLabs/ldns/issues

## COPYRIGHT

Copyright (c) 2004 - 2006 NLnet Labs.

Licensed under the BSD License. There is NO warranty; not even for MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE.

## SEE ALSO

**perldoc Net::DNS**, **RFC1034**, **RFC1035**, **RFC4033**, **RFC4034** and **RFC4035**.

## REMARKS

This manpage was automatically generated from the ldns source code.
