---
name: "ldns_dname_compare"
section: "3"
platform: "linux"
package: "ldns"
version: "1.9.2-1"
release: "Arch Linux 2026-11-01"
platforms: ["linux"]
url: "https://new.carta.tech/ldns_dname_compare"
---

# ldns\_dname\_compare(3)

compare two dnames

## NAME

ldns\_dname\_compare, ldns\_dname\_interval - compare two dnames

## SYNOPSIS

\#include \<stdint.h\>\
 \#include \<stdbool.h\>\

\#include \<ldns/ldns.h\>

int ldns\_dname\_compare(const ldns\_rdf \*dname1, const ldns\_rdf \*dname2);

int ldns\_dname\_interval(const ldns\_rdf \*prev, const ldns\_rdf \*middle, const ldns\_rdf \*next);

## DESCRIPTION

*ldns\_dname\_compare*() Compares the two dname rdf's according to the algorithm for ordering in RFC4034 Section 6. .br **dname1**: First dname rdf to compare .br **dname2**: Second dname rdf to compare .br Returns -1 if dname1 comes before dname2, 1 if dname1 comes after dname2, and 0 if they are equal.

*ldns\_dname\_interval*() check if middle lays in the interval defined by prev and next prev \<= middle \< next. This is useful for nsec checking .br **prev**: the previous dname .br **middle**: the dname to check .br **next**: the next dname return 0 on error or unknown, -1 when middle is in the interval, +1 when not

## AUTHOR

The ldns team at NLnet Labs.

## REPORTING BUGS

Please report bugs to dns-team@nlnetlabs.nl or on GitHub at https://github.com/NLnetLabs/ldns/issues

## COPYRIGHT

Copyright (c) 2004 - 2006 NLnet Labs.

Licensed under the BSD License. There is NO warranty; not even for MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE.

## SEE ALSO

*ldns\_dname\_is\_subdomain*. And **perldoc Net::DNS**, **RFC1034**, **RFC1035**, **RFC4033**, **RFC4034**  and **RFC4035**.

## REMARKS

This manpage was automatically generated from the ldns source code.
