---
name: "ldns_dname_cat_clone"
section: "3"
platform: "linux"
package: "ldns"
version: "1.9.2-1"
release: "Arch Linux 2026-11-01"
platforms: ["linux"]
url: "https://new.carta.tech/ldns_dname_cat_clone"
---

# ldns\_dname\_cat\_clone(3)

concatenate two dnames

## NAME

ldns\_dname\_cat\_clone, ldns\_dname\_cat - concatenate two dnames

## SYNOPSIS

\#include \<stdint.h\>\
 \#include \<stdbool.h\>\

\#include \<ldns/ldns.h\>

ldns\_rdf\* ldns\_dname\_cat\_clone(const ldns\_rdf \*rd1, const ldns\_rdf \*rd2);

ldns\_status ldns\_dname\_cat(ldns\_rdf \*rd1, const ldns\_rdf \*rd2);

## DESCRIPTION

*ldns\_dname\_cat\_clone*() concatenates two dnames together .br **rd1**: the leftside .br **rd2**: the rightside .br Returns a new rdf with leftside/rightside

*ldns\_dname\_cat*() concatenates rd2 after rd1 (rd2 is copied, rd1 is modified) .br **rd1**: the leftside .br **rd2**: the rightside .br Returns LDNS\_STATUS\_OK on success

## AUTHOR

The ldns team at NLnet Labs.

## REPORTING BUGS

Please report bugs to dns-team@nlnetlabs.nl or on GitHub at https://github.com/NLnetLabs/ldns/issues

## COPYRIGHT

Copyright (c) 2004 - 2006 NLnet Labs.

Licensed under the BSD License. There is NO warranty; not even for MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE.

## SEE ALSO

**perldoc Net::DNS**, **RFC1034**, **RFC1035**, **RFC4033**, **RFC4034** and **RFC4035**.

## REMARKS

This manpage was automatically generated from the ldns source code.
