---
name: "ldns_dname"
section: "3"
platform: "linux"
package: "libldns-dev"
version: "1.6.17-5+b1"
release: "Debian 8 (Jessie)"
platforms: ["linux"]
url: "https://new.carta.tech/ldns_dname"
---

# ldns\_dname(3)

## NAME

ldns\_dname-

## SYNOPSIS

\#include \<stdint.h\>\
 \#include \<stdbool.h\>\

\#include \<ldns/ldns.h\>

 ldns\_dname();

## DESCRIPTION

*ldns\_dname*()

## AUTHOR

The ldns team at NLnet Labs. Which consists out of Jelte Jansen and Miek Gieben.

## REPORTING BUGS

Please report bugs to ldns-team@nlnetlabs.nl or in  our bugzilla at http://www.nlnetlabs.nl/bugs/index.html

## COPYRIGHT

Copyright (c) 2004 - 2006 NLnet Labs.

Licensed under the BSD License. There is NO warranty; not even for MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE.

## SEE ALSO

*ldns\_dname\_left\_chop*, *ldns\_dname\_label\_count*, *ldns\_dname2canonical*, *ldns\_dname\_cat*, *ldns\_dname\_cat\_clone*, *ldns\_dname\_new*, *ldns\_dname\_new\_frm\_str*, *ldns\_dname\_new\_frm\_data*, *ldns\_dname\_is\_subdomain*, *ldns\_dname\_str\_absolute*, *ldns\_dname\_label*, *ldns\_dname\_compare*, *ldns\_dname\_interval*. And **perldoc Net::DNS**, **RFC1034**, **RFC1035**, **RFC4033**, **RFC4034**  and **RFC4035**.

## REMARKS

This manpage was automaticly generated from the ldns source code by use of Doxygen and some perl.
