---
name: "ldns_calc_keytag"
section: "3"
platform: "linux"
package: "ldns"
version: "1.9.2-1"
release: "Arch Linux 2026-11-01"
platforms: ["linux"]
url: "https://new.carta.tech/ldns_calc_keytag"
---

# ldns\_calc\_keytag(3)

calculate ldns keytag

## NAME

ldns\_calc\_keytag, ldns\_calc\_keytag\_raw - calculate ldns keytag

## SYNOPSIS

\#include \<stdint.h\>\
 \#include \<stdbool.h\>\

\#include \<ldns/ldns.h\>

uint16\_t ldns\_calc\_keytag(const ldns\_rr \*key);

uint16\_t ldns\_calc\_keytag\_raw(const uint8\_t\* key, size\_t keysize);

## DESCRIPTION

*ldns\_calc\_keytag*() calculates a keytag of a key for use in DNSSEC.

.br **key**: the key as an RR to use for the calc. .br Returns the keytag

*ldns\_calc\_keytag\_raw*() Calculates keytag of DNSSEC key, operates on wireformat rdata. .br **key**: the key as uncompressed wireformat rdata. .br **keysize**: length of key data. .br Returns the keytag

## AUTHOR

The ldns team at NLnet Labs.

## REPORTING BUGS

Please report bugs to dns-team@nlnetlabs.nl or on GitHub at https://github.com/NLnetLabs/ldns/issues

## COPYRIGHT

Copyright (c) 2004 - 2006 NLnet Labs.

Licensed under the BSD License. There is NO warranty; not even for MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE.

## SEE ALSO

*ldns\_key*. And **perldoc Net::DNS**, **RFC1034**, **RFC1035**, **RFC4033**, **RFC4034**  and **RFC4035**.

## REMARKS

This manpage was automatically generated from the ldns source code.
