---
name: "ldns_buffer_status_ok"
section: "3"
platform: "linux"
package: "ldns"
version: "1.9.2-1"
release: "Arch Linux 2026-11-01"
platforms: ["linux"]
url: "https://new.carta.tech/ldns_buffer_status_ok"
---

# ldns\_buffer\_status\_ok(3)

check buffer status

## NAME

ldns\_buffer\_remaining\_at, ldns\_buffer\_remaining, ldns\_buffer\_available\_at, ldns\_buffer\_available, ldns\_buffer\_status, ldns\_buffer\_status\_ok - check buffer status

## SYNOPSIS

\#include \<stdint.h\>\
 \#include \<stdbool.h\>\

\#include \<ldns/ldns.h\>

size\_t ldns\_buffer\_remaining\_at(const ldns\_buffer \*buffer, size\_t at);

size\_t ldns\_buffer\_remaining(const ldns\_buffer \*buffer);

int ldns\_buffer\_available\_at(const ldns\_buffer \*buffer, size\_t at, size\_t count);

int ldns\_buffer\_available(const ldns\_buffer \*buffer, size\_t count);

ldns\_status ldns\_buffer\_status(const ldns\_buffer \*buffer);

bool ldns\_buffer\_status\_ok(const ldns\_buffer \*buffer);

## DESCRIPTION

*ldns\_buffer\_remaining\_at*() returns the number of bytes remaining between the indicated position and the limit. .br **buffer**: the buffer .br **at**: indicated position .br Returns number of bytes

*ldns\_buffer\_remaining*() returns the number of bytes remaining between the buffer's position and limit. .br **buffer**: the buffer .br Returns the number of bytes

*ldns\_buffer\_available\_at*() checks if the buffer has at least COUNT more bytes available. Before reading or writing the caller needs to ensure enough space is available! .br **buffer**: the buffer .br **at**: indicated position .br **count**: how much is available .br Returns true or false (as int?)

*ldns\_buffer\_available*() checks if the buffer has count bytes available at the current position .br **buffer**: the buffer .br **count**: how much is available .br Returns true or false (as int?)

*ldns\_buffer\_status*() returns the status of the buffer \\param\[in\] buffer .br Returns the status

*ldns\_buffer\_status\_ok*() returns true if the status of the buffer is LDNS\_STATUS\_OK, false otherwise .br **buffer**: the buffer .br Returns true or false

## AUTHOR

The ldns team at NLnet Labs.

## REPORTING BUGS

Please report bugs to dns-team@nlnetlabs.nl or on GitHub at https://github.com/NLnetLabs/ldns/issues

## COPYRIGHT

Copyright (c) 2004 - 2006 NLnet Labs.

Licensed under the BSD License. There is NO warranty; not even for MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE.

## SEE ALSO

*ldns\_buffer*. And **perldoc Net::DNS**, **RFC1034**, **RFC1035**, **RFC4033**, **RFC4034**  and **RFC4035**.

## REMARKS

This manpage was automatically generated from the ldns source code.
