---
name: "ldns_buffer_position"
section: "3"
platform: "linux"
package: "ldns"
version: "1.9.2-1"
release: "Arch Linux 2026-11-01"
platforms: ["linux"]
url: "https://new.carta.tech/ldns_buffer_position"
---

# ldns\_buffer\_position(3)

buffer positioning

## NAME

ldns\_buffer\_flip, ldns\_buffer\_rewind, ldns\_buffer\_position, ldns\_buffer\_set\_position, ldns\_buffer\_skip - buffer positioning

## SYNOPSIS

\#include \<stdint.h\>\
 \#include \<stdbool.h\>\

\#include \<ldns/ldns.h\>

void ldns\_buffer\_flip(ldns\_buffer \*buffer);

void ldns\_buffer\_rewind(ldns\_buffer \*buffer);

size\_t ldns\_buffer\_position(const ldns\_buffer \*buffer);

void ldns\_buffer\_set\_position(ldns\_buffer \*buffer, size\_t mark);

void ldns\_buffer\_skip(ldns\_buffer \*buffer, ssize\_t count);

## DESCRIPTION

*ldns\_buffer\_flip*() makes the buffer ready for reading the data that has been written to the buffer.  The buffer's limit is set to the current position and the position is set to 0.

.br **buffer**: the buffer to flip .br Returns void

*ldns\_buffer\_rewind*() make the buffer ready for re-reading the data.  The buffer's position is reset to 0. .br **buffer**: the buffer to rewind

*ldns\_buffer\_position*() returns the current position in the buffer (as a number of bytes) .br **buffer**: the buffer .br Returns the current position

*ldns\_buffer\_set\_position*() sets the buffer's position to MARK.  The position must be less than or equal to the buffer's limit. .br **buffer**: the buffer .br **mark**: the mark to use

*ldns\_buffer\_skip*() changes the buffer's position by COUNT bytes.  The position must not be moved behind the buffer's limit or before the beginning of the buffer. .br **buffer**: the buffer .br **count**: the count to use

## AUTHOR

The ldns team at NLnet Labs.

## REPORTING BUGS

Please report bugs to dns-team@nlnetlabs.nl or on GitHub at https://github.com/NLnetLabs/ldns/issues

## COPYRIGHT

Copyright (c) 2004 - 2006 NLnet Labs.

Licensed under the BSD License. There is NO warranty; not even for MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE.

## SEE ALSO

*ldns\_buffer*. And **perldoc Net::DNS**, **RFC1034**, **RFC1035**, **RFC4033**, **RFC4034**  and **RFC4035**.

## REMARKS

This manpage was automatically generated from the ldns source code.
