---
name: "ldns_bubblebabble"
section: "3"
platform: "linux"
package: "ldns"
version: "1.9.2-1"
release: "Arch Linux 2026-11-01"
platforms: ["linux"]
url: "https://new.carta.tech/ldns_bubblebabble"
---

# ldns\_bubblebabble(3)

encode data as BubbleBabble

## NAME

ldns\_bubblebabble - encode data as BubbleBabble

## SYNOPSIS

\#include \<stdint.h\>\
 \#include \<stdbool.h\>\

\#include \<ldns/ldns.h\>

char\* ldns\_bubblebabble(uint8\_t \*data, size\_t len);

## DESCRIPTION

*ldns\_bubblebabble*() Encode data as BubbleBabble

.br **data**: a pointer to data to be encoded .br **len**: size the number of bytes of data .br Returns a string of BubbleBabble

## AUTHOR

The ldns team at NLnet Labs.

## REPORTING BUGS

Please report bugs to dns-team@nlnetlabs.nl or on GitHub at https://github.com/NLnetLabs/ldns/issues

## COPYRIGHT

Copyright (c) 2004 - 2006 NLnet Labs.

Licensed under the BSD License. There is NO warranty; not even for MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE.

## SEE ALSO

**perldoc Net::DNS**, **RFC1034**, **RFC1035**, **RFC4033**, **RFC4034** and **RFC4035**.

## REMARKS

This manpage was automatically generated from the ldns source code.
