---
name: "ldns_bskipcs"
section: "3"
platform: "linux"
package: "ldns"
version: "1.9.2-1"
release: "Arch Linux 2026-11-01"
platforms: ["linux"]
url: "https://new.carta.tech/ldns_bskipcs"
---

# ldns\_bskipcs(3)

get tokens from buffers

## NAME

ldns\_bget\_token, ldns\_bgetc, ldns\_bskipcs - get tokens from buffers

## SYNOPSIS

\#include \<stdint.h\>\
 \#include \<stdbool.h\>\

\#include \<ldns/ldns.h\>

ssize\_t ldns\_bget\_token(ldns\_buffer \*b, char \*token, const char \*delim, size\_t limit);

int ldns\_bgetc(ldns\_buffer \*buffer);

void ldns\_bskipcs(ldns\_buffer \*buffer, const char \*s);

## DESCRIPTION

*ldns\_bget\_token*() returns a token/char from the buffer b. This function deals with ( and ) in the buffer, and ignores when it finds them. .br **\*b**: the buffer to read from .br **\*token**: the token is put here .br **\*delim**: chars at which the parsing should stop .br **\*limit**: how much to read. If 0 the builtin maximum is used .br Returns s 0 on error of EOF of b. Otherwise return the length of what is read

*ldns\_bgetc*() returns the next character from a buffer. Advances the position pointer with 1. When end of buffer is reached returns EOF. This is the buffer's equivalent for getc(). .br **\*buffer**: buffer to read from .br Returns EOF on failure otherwise return the character

*ldns\_bskipcs*() skips all of the characters in the given string in the buffer, moving the position to the first character that is not in \*s. .br **\*buffer**: buffer to use .br **\*s**: characters to skip .br Returns void

## AUTHOR

The ldns team at NLnet Labs.

## REPORTING BUGS

Please report bugs to dns-team@nlnetlabs.nl or on GitHub at https://github.com/NLnetLabs/ldns/issues

## COPYRIGHT

Copyright (c) 2004 - 2006 NLnet Labs.

Licensed under the BSD License. There is NO warranty; not even for MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE.

## SEE ALSO

*ldns\_buffer*. And **perldoc Net::DNS**, **RFC1034**, **RFC1035**, **RFC4033**, **RFC4034**  and **RFC4035**.

## REMARKS

This manpage was automatically generated from the ldns source code.
