---
name: "ldns_b32_ntop_calculate_size"
section: "3"
platform: "linux"
package: "ldns"
version: "1.9.2-1"
release: "Arch Linux 2026-11-01"
platforms: ["linux"]
url: "https://new.carta.tech/ldns_b32_ntop_calculate_size"
---

# ldns\_b32\_ntop\_calculate\_size(3)

return size needed for b32 or b64 encoded or decoded data

## NAME

ldns\_b32\_ntop\_calculate\_size, ldns\_b32\_pton\_calculate\_size, ldns\_b64\_ntop\_calculate\_size, ldns\_b64\_pton\_calculate\_size - return size needed for b32 or b64 encoded or decoded data

## SYNOPSIS

\#include \<stdint.h\>\
 \#include \<stdbool.h\>\

\#include \<ldns/ldns.h\>

size\_t ldns\_b32\_ntop\_calculate\_size(size\_t src\_data\_length);

size\_t ldns\_b32\_pton\_calculate\_size(size\_t src\_text\_length);

static inline size\_t ldns\_b64\_ntop\_calculate\_size(size\_t srcsize){ return ((((srcsize + 2) / 3) \* 4) + 1);

static inline size\_t ldns\_b64\_pton\_calculate\_size(size\_t srcsize){ return (((((srcsize + 3) / 4) \* 3)) + 1);

## DESCRIPTION

*ldns\_b32\_ntop\_calculate\_size*() calculates the size needed to store the result of b32\_ntop

*ldns\_b32\_pton\_calculate\_size*() calculates the size needed to store the result of b32\_pton

*ldns\_b64\_ntop\_calculate\_size*() calculates the size needed to store the result of b64\_ntop

*ldns\_b64\_pton\_calculate\_size*() calculates the size needed to store the result of ldns\_b64\_pton

## AUTHOR

The ldns team at NLnet Labs.

## REPORTING BUGS

Please report bugs to dns-team@nlnetlabs.nl or on GitHub at https://github.com/NLnetLabs/ldns/issues

## COPYRIGHT

Copyright (c) 2004 - 2006 NLnet Labs.

Licensed under the BSD License. There is NO warranty; not even for MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE.

## SEE ALSO

**perldoc Net::DNS**, **RFC1034**, **RFC1035**, **RFC4033**, **RFC4034** and **RFC4035**.

## REMARKS

This manpage was automatically generated from the ldns source code.
