---
name: "ldns_algorithm"
section: "3"
platform: "linux"
package: "ldns"
version: "1.9.2-1"
release: "Arch Linux 2026-11-01"
platforms: ["linux"]
url: "https://new.carta.tech/ldns_algorithm"
---

# ldns\_algorithm(3)

numbers assigned to algorithms used in dns

## NAME

ldns\_algorithm - numbers assigned to algorithms used in dns

## SYNOPSIS

\#include \<stdint.h\>\
 \#include \<stdbool.h\>\

\#include \<ldns/ldns.h\>

## DESCRIPTION

*ldns\_algorithm*\
 Algorithms used in dns\
 enum ldns\_enum\_algorithm\
 {\
\
         LDNS\_RSAMD5             = 1,   /\* RFC 4034,4035 \*/\
\
         LDNS\_DH                 = 2,\
\
         LDNS\_DSA                = 3,\
\
         LDNS\_ECC                = 4,\
\
         LDNS\_RSASHA1            = 5,\
\
         LDNS\_DSA\_NSEC3          = 6,\
\
         LDNS\_RSASHA1\_NSEC3      = 7,\
\
         LDNS\_RSASHA256          = 8,   /\* RFC 5702 \*/\
\
         LDNS\_RSASHA512          = 10,  /\* RFC 5702 \*/\
\
         LDNS\_ECC\_GOST           = 12,  /\* RFC 5933 \*/\
\
         LDNS\_ECDSAP256SHA256    = 13,  /\* RFC 6605 \*/\
\
         LDNS\_ECDSAP384SHA384    = 14,  /\* RFC 6605 \*/\
\
 	LDNS\_ED25519		= 15,  /\* RFC 8080 \*/\
\
 	LDNS\_ED448		= 16,  /\* RFC 8080 \*/\
\
         LDNS\_INDIRECT           = 252,\
\
         LDNS\_PRIVATEDNS         = 253,\
\
         LDNS\_PRIVATEOID         = 254\
 };\
 typedef enum ldns\_enum\_algorithm ldns\_algorithm;

## AUTHOR

The ldns team at NLnet Labs.

## REPORTING BUGS

Please report bugs to dns-team@nlnetlabs.nl or on GitHub at https://github.com/NLnetLabs/ldns/issues

## COPYRIGHT

Copyright (c) 2004 - 2006 NLnet Labs.

Licensed under the BSD License. There is NO warranty; not even for MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE.

## SEE ALSO

**perldoc Net::DNS**, **RFC1034**, **RFC1035**, **RFC4033**, **RFC4034** and **RFC4035**.

## REMARKS

This manpage was automatically generated from the ldns source code.
