---
name: "emil.cf"
section: "5"
platform: "linux"
package: "emil"
version: "2.1.0-beta9.dfsg-1.1"
release: "Debian 6.0 (Squeeze)"
platforms: ["linux"]
url: "https://new.carta.tech/emil.cf"
---

# emil.cf(5)

configuration file for emil(1)

## NAME

emil.cf - configuration file for [emil(1)](/emil/1.md)

## SYNOPSIS

**group** *Group\_Name*: \[ **charset=** *CHARSET* *,* \] \[ **format=** *FORMAT* *,* \] \[ **appletype=** *ENCODING* *,* \] \[ **bin=** *ENCODING* *,* \] \[ **textenc=** *ENCODING* *,* \] \[ **henc=** *ENCODING* \] *;*

**match** *Context*  *Match\_String*  *OUT* ;

**member** *Group\_Name* :  *Recipient*  *Sender*  *Recipient\_host*  , **...** ;

**mailer** *Mailer\_Name* :  *Path,*  *Program,*  *Arguments,*  ... **;**

## DESCRIPTION

The file  /etc/emil.cf is used by [emil(1)](/emil/1.md) to decide which conversions should be applied to a specific Internet  message. Conversion is controlled by the combination of  *Sender,* *Recipient* and *Recipient\_host* and the corresponding group line.

When emil is executed it first visits  /etc/emil.cf with the arguments *Sender,* *Recipient* and *Recipient\_host* to extract the name of target group (as specified by the  **member** fields). A subsequent check with the **group** fields yields the target group structure, containing *charset,* *format,* *bin,* *textenc* and *henc.* Then the *Sender* and *Recipient* is swapped to get the corresponding information about the sender.

## COMMANDS

Commands may appear in any order. They are all ended with a semi colon ";".

- **group**

  Defines a group by a group name and a comma separated list of options.

  *Group\_name* - Name of the group.

  charset - Specifies the charset used by the group, according to RFC1345.

  format - Specifies the format used by the group. Pick one of: MIME, MAILTOOL, RFC822 or TRANSPARENT. Default is RFC822.

  appletype - Specifies the format to be used for applefile attachments. Pick one of Binhex, appleDouble or appleSingle.

  bin - Specifies the encoding to be used for binary attachments. Pick one of BAse64, BInhex or Uuencode.

  textenc - Specifies the encoding to be used for text. Pick one of BAse64, BInhex, Uuencode, Quoted-printable, 8bit, Se or 7bit. 7bit is default. When 7bit is chosen the text is first converted to ISO-8859-1 and then the 8bit characters are replaced by the english characters with closest resemblance. When Se is chosen the text is first converted to ISO-8859-1 and then the 8bit characters are replaced by the appropriate characters as specified by some national variants of ISO-646. This special conversion is suited to work in Sweden but works probably also for other european languages.

  henc - Specifies the encoding to be used for header lines. Pick one of Base64, Quoted-printable, 8bit or Se, 7bit. 7bit is default. If BAse64 or Quoted-Printable is selected headers are converted according to RFC1522 (MIME-II). 7bit and Se behaives like in the textenc field.

- **match**

  This field is used to build a list of types and the corresponding expression in the given context.

  *Context* - One of MAILTOOL, MIME, BINHEX or UUENCODE.

  *OUT* - The generic type of the field

  *Match\_String* - A quoted string that corresponds to the  *Context* of the field. For MAILTOOL *Match\_String* defines the Sun Mailtool X-Sun-Data\_type to be used. For MIME *Match\_String* defines the content-type to be used. For UUENCODE  *Match\_String* defines the file name extension to be used. For BINHEX *Match\_String* defines the merged two 4byte strings Type and Auth info.

- **member**

  Defines members of a group given as a group name and a comma separated list of the triples  *Recipient,* *Sender* and *Recipient\_host.* Either one in the triples can be totally or partly replaced by a wildcard '\*'.

  *Group\_name* - Name of the group.

  *Sender* - Sender's mail address.

  *Recipient* - Recipient's mail address.

  *Recipient\_host* - Name of the recipient host or relay.

- **mailer**

  Defines a mailer (or tags a program) as a mailer name and a comma separated list of arguments that makes up the execv vector of the program to execute.

  *Mailer\_name* - Name of the mailer.

  *Path* - Path of the program to execute.

  *Program* - Name of the program to execute

  *Arguments* - A list of each command line argument to use when invoking the program. To be suitable for mail programs you can specify variables representing sender, recipient and mail relay. These are specified by $s, $r and $x respectively.

## AUTHOR

Martin Wendel (Martin.Wendel@its.uu.se) and Torbjorn Wictorin (Torbjorn.Wictorin@its.uu.se)

## SEE ALSO

[emil(1)](/emil/1.md)

## BUGS

None
