Reference

dtrace_mib(4)

a DTrace provider for Management Information Base

NAME

dtrace_mib – a DTrace provider for Management Information Base

SYNOPSIS

mib:module:count:counter

In config(5): options KDTRACE_MIB_SDT

DESCRIPTION

The mib provider allows tracing of Management Information Base stats counters.

The list of instrumented modules includes:

ah

IP Authentication Header (RFC 2402), ipsec(4)

esp

IP Encapsulating Security Payload (RFC 1827, RFC 2406), ipsec(4)

icmp

icmp(4)

icmp6

icmp6(4)

ip

ip(4)

ip6

ip6(4)

ipcomp

IP Payload Compression Protocol, ipsec(4)

ipsec

ipsec(4)

tcp

tcp(4)

udp

udp(4)

The mib:module:count:counter probes fire when the counter in modules increases.

The first probe argument, uint64_t args[0], is the increment that the counter will increase by.

Note that some probes like mib:esp:count:esps_hist or mib:icmp6:count:icp6s_outhist provide additional probe-specific arguments.

EXAMPLES

Example 1 : Tracing IP Stats Counters

When debugging network issues one common clue is an unexpectedly incrementing error counter. This is helpful, in that it gives us an idea of what might be going wrong, but often these counters may be incremented in different functions.

Trace all mib probes in the ip(4) module and print the current count and a stack trace:

# dtrace -n 'mib:ip:count: { printf("%d", arg0); stack(); }'
dtrace: description 'mib:ip:count: ' matched 29 probes
CPU     ID                    FUNCTION:NAME
  7  98784               count:ips_localout 1
              kernel`ip_output+0x17a2
              kernel`udp_send+0xaca
              kernel`sosend_dgram+0x315
              kernel`sousrsend+0x79
              kernel`kern_sendit+0x1be
              kernel`sendit+0x1ab
              kernel`sys_sendmsg+0x5b
              kernel`amd64_syscall+0x169
              kernel`0xffffffff81094b8b

SEE ALSO

dtrace(1), dtrace_ip(4), dtrace_tcp(4), dtrace_udp(4), tracing(7), sysctl(8)

STANDARDS

The probe descriptions in the FreeBSD mib provider are not compatible with those in the Solaris/illumos mib provider.

AUTHORS

The mib provider was added to FreeBSD by Kristof Provost ⟨[email protected]⟩.

This manual page was written by Mateusz Piotrowski ⟨[email protected]⟩.