Reference

dns(3tnm)

Query the Domain Name System of the Internet.


        
    

    
        

NAME

Tnm::dns - Query the Domain Name System of the Internet.


        
    


        

DESCRIPTION

The Tnm::dns command allows to query the Internet Domain Name System (DNS) (RFC 1034, RFC 1035, RFC 974, RFC 1912) for host information. The main purpose of this command is to convert host names into IP addresses and vice versa. The Tnm::dns command also allows to retrieve host information records as well as mail exchanger records.

DNS COMMAND

Tnm::dns [options]

Invoking the Tnm::dns command with options but without any command arguments allows to retrieve and change the default values. See the description of supported options below. Default values are bound to a Tcl interpreter which allows to have multiple Tcl interpreter with different defaults.

Tnm::dns [options] address host

The Tnm::dns address command sends a query to retrieve the address record for the specified host. The command returns the list of IP addresses for the given host name.

Tnm::dns [options] name address

The Tnm::dns name command sends a query to retrieve the domain name pointer record. A pointer record maps an IP address to a fully qualified domain name. The command returns the fully qualified domain name for the given IP address.

Tnm::dns [options] hinfo name

The Tnm::dns hinfo command sends a query to retrieve the host information (HINFO) record. The command returns a list containing two elements. The first element describes the hardware type and the second element the operating system.

Tnm::dns [options] mx name

The Tnm::dns mx command sends a query to retrieve the mail exchanger (MX) record. The command returns a list of mail exchanger records if name is a domain name for which one or more MX records exist. Each element of this list contains a fully qualified domain name and its priority.

Tnm::dns [options] soa name

The Tnm::dns soa command sends a query to retrieve the start of authority record for a DNS domain. The command returns the name of the authoritative DNS server of the DNS domain name.

DNS OPTIONS

-server server

The -server option defines the list of DNS server which will be used to process the request. The default value is the list of default DNS server configured on the local system.

-timeout time

The -timeout option defines the time the dns command will wait for a response. The time is defined in seconds with a default of 2 seconds.

-retries number

The -retries option defines how many times a request is retransmitted during the timeout interval. The default number of retries is 2. Please note, that many resolver double the last timeout after every retry.

SEE ALSO

scotty(1), Tnm(n), Tcl(n)

AUTHORS

Erik Schoenfelder <[email protected]>
Juergen Schoenwaelder <[email protected]>

History