---
name: "dacslist"
section: "1"
platform: "linux"
package: "dacs"
version: "1.4.40-2"
release: "Debian 10 (Buster)"
platforms: ["linux"]
url: "https://new.carta.tech/dacslist"
---

# dacslist(1)

list jurisdictions

## NAME

dacslist - list jurisdictions

## SYNOPSIS

**dacslist** \[**dacsoptions**\[1\]\] \[**-f**\] \[**-j** *jurisdiction-name*\] \[**-k**\]

## DESCRIPTION

This program is part of the **DACS** suite.

For a jurisdiction configured on the host where this program is run, the **dacslist** utility lists information about all known jurisdictions in the same federation. It can also display information about the federation.

This program is also available as a **DACS** web service, **[dacs\_list\_jurisdictions(8)](/dacs_list_jurisdictions/8.md)**\[2\].

**Security**\

Because this program may access the federation and jurisdiction key files (item types federation\_keys and jurisdiction\_keys, respectively), only the **DACS** administrator should be able to run this command.

## OPTIONS

The program respects the **-format** flag. Except for error messages, information is printed to the standard output.

- **-f**

  Only list information about the federation. Equivalent to -j "".

- **-j** *jurisdiction-name*

  Limit the output to the specified jurisdiction name. As a special case, if the argument is the empty string, only federation-scoped information will be returned.

- **-k**

  Only the federation's or a jurisdiction's public key (if known) will be displayed. If **-j** is given and is not the empty string, that jurisdiction name is selected; if **-j** is given and is the empty string, the federation is selected; and if the argument is absent, the current jurisdiction is selected. A PEM \[**RFC 1421**\[3\], **RFC 1422**\[4\], **RFC 1423**\[5\], **RFC 1424**\[6\]\] formatted key is returned.

**Note**\

In the current implementation, a jurisdiction's public key can only be provided by one of the jurisdictions configured on the same host.

## EXAMPLES

To list all jurisdictions in the same federation as jurisdiction J1, which must be configured on this host:

```
% dacslist -uj J1
```

To copy the public encryption key for J1 to pubkey:

```
% dacslist -uj J1 -k > pubkey
```

To display the public encryption key for J1's federation:

```
% dacslist -uj J1 -f -k
```

To retrieve the public encryption key for J1, which must be in the same federation as J2:

```
% dacslist -uj J2 -k -j J1
```

To display information about the federation to which jurisdiction J1 belongs:

```
% dacslist -uj J1 -f
```

## DIAGNOSTICS

The program exits 0 if everything was fine, 1 if an error occurred. Error messages are printed to stderr.

## SEE ALSO

**[dacs\_list\_jurisdictions(8)](/dacs_list_jurisdictions/8.md)**\[2\], **[dacs.groups(5)](/dacs.groups/5.md)**\[7\]

## AUTHOR

Distributed Systems Software (**www.dss.ca**\[8\])

## COPYING

Copyright © 2003-2012 Distributed Systems Software. See the **LICENSE**\[9\] file that accompanies the distribution for licensing information.

## NOTES

- 1\.

  dacsoptions

  http://dacs.dss.ca/man/dacs.1.html#dacsoptions

- 2\.

  [dacs\_list\_jurisdictions(8)](/dacs_list_jurisdictions/8.md)

  http://dacs.dss.ca/man/dacs\_list\_jurisdictions.8.html

- 3\.

  RFC 1421

  http://www.rfc-editor.org/rfc/rfc1421.txt

- 4\.

  RFC 1422

  http://www.rfc-editor.org/rfc/rfc1422.txt

- 5\.

  RFC 1423

  http://www.rfc-editor.org/rfc/rfc1423.txt

- 6\.

  RFC 1424

  http://www.rfc-editor.org/rfc/rfc1424.txt

- 7\.

  [dacs.groups(5)](/dacs.groups/5.md)

  http://dacs.dss.ca/man/dacs.groups.5.html

- 8\.

  www.dss.ca

  http://www.dss.ca

- 9\.

  LICENSE

  http://dacs.dss.ca/man/../misc/LICENSE
