carta
coap(7)

coap7

Overview of the libcoap library

Overview

libcoap is a C implementation of a lightweight application-protocol for devices that are constrained by their resources such as computing power, RF range, memory, bandwidth, or network packet sizes. This protocol, CoAP, is standardized by the IETF as RFC7252. For further information related to CoAP, see http://coap.technology.

Documentation for the specific library calls with examples can be found in the man pages referred to in SEE ALSO.

Further information can be found in the include header files with example code provided in the examples directory.

NOTE: This documentation is a work in progress. Any missing information can be found in the include header files along with example code provided in the examples directory.

Further information

See

"RFC7252: The Constrained Application Protocol (CoAP)"

"RFC7390: Group Communication for the Constrained Application Protocol (CoAP)"

"RFC7641: Observing Resources in the Constrained Application Protocol (CoAP)"

"RFC7959: Block-Wise Transfers in the Constrained Application Protocol (CoAP)"

"RFC7967: Constrained Application Protocol (CoAP) Option for No Server Response"

"RFC8132: PATCH and FETCH Methods for the Constrained Application Protocol (CoAP)"

"RFC8323: CoAP (Constrained Application Protocol) over TCP, TLS, and WebSockets"

"RFC8516: "Too Many Requests" Response Code for the Constrained Application Protocol"

"RFC8613: Object Security for Constrained RESTful Environments (OSCORE)"

"RFC8768: Constrained Application Protocol (CoAP) Hop-Limit Option"

"RFC8974: Extended Tokens and Stateless Clients in the Constrained Application Protocol (CoAP)"

"RFC9175: CoAP: Echo, Request-Tag, and Token Processing"

"RFC9177: Constrained Application Protocol (CoAP) Block-Wise Transfer Options Supporting Robust Transmission"

for further information.

History

  • Debian 13 (Trixie): the text shown here
  • Debian 12 (Bookworm)
  • Debian 11 (Bullseye)
  • Debian 10 (Buster)

Bugs

Please report bugs on the mailing list for libcoap: [email protected] or raise an issue on GitHub at https://github.com/obgm/libcoap/issues

Authors

The libcoap project <[email protected]>

From libcoap3t64 4.3.4-1.1+deb13u3 in Debian 13 (Trixie). Parsed by carta from the page's man source.