---
name: "Net::LibIDN2"
section: "3pm"
platform: "linux"
package: "perl-net-libidn2"
version: "1.02-6"
release: "Arch Linux 2026-11-01"
platforms: ["linux"]
url: "https://new.carta.tech/Net::LibIDN2"
---

# Net::LibIDN2(3pm)

Perl bindings for GNU Libidn2

## NAME

Net::LibIDN2 - Perl bindings for GNU Libidn2

## SYNOPSIS

```
  use Net::LibIDN2 ':all';
  use Encode;
  idn2_lookup_u8(Encode::encode_utf8("m\N{U+00FC}\N{U+00DF}li.de"))
    eq 'xn--mli-5ka8l.de';
  idn2_register_u8(
    Encode::encode_utf8("m\N{U+00FC}\N{U+00DF}li"),
    "xn--mli-5ka8l"
  ) eq 'xn--mli-5ka8l';
  Encode::decode_utf8(idn2_to_unicode_88("xn--mli-5ka8l.de"))
    eq "m\N{U+00FC}\N{U+00DF}li.de"
```

## DESCRIPTION

Provides bindings for GNU Libidn2, a C library for handling internationalized domain names based on IDNA 2008, Punycode and TR46.

### Functions

- **Net::LibIDN2::idn2\_lookup\_u8**(*$src*, \[*$flags*, \[*$rc*\]\]);

  Alternative name idn2\_to\_ascii\_8.

  Perform IDNA2008 lookup string conversion on domain name $*src*, as described in  section 5 of RFC 5891. Note that the input string must be encoded in UTF-8 and be in Unicode NFC form.

  Pass **IDN2\_NFC\_INPUT** in *$flags* to convert input to NFC form before further processing. IDN2\_TRANSITIONAL and IDN2\_NONTRANSITIONAL do already imply IDN2\_NFC\_INPUT.

  Pass **IDN2\_ALABEL\_ROUNDTRIP** in flags to convert any input A-labels to U-labels and perform additional testing. This is default if used with a libidn2 version \>= 2.2. To switch this behavior off, pass IDN2\_NO\_ALABEL\_ROUNDTRIP.

  Pass IDN2\_TRANSITIONAL to enable Unicode TR46 transitional processing, and IDN2\_NONTRANSITIONAL to enable Unicode TR46 non-transitional processing.

  Multiple flags may be specified by binary or:ing them together, for example **IDN2\_NFC\_INPUT** \| **IDN2\_ALABEL\_ROUNDTRIP**.

  If linked to library GNU Libidn2 version \> 2.0.3: IDN2\_USE\_STD3\_ASCII\_RULES disabled by default. Previously we were eliminating non-STD3 characters from domain strings such as \_443.\_tcp.example.com, or IPs 1.2.3.4/24 provided to libidn2 functions. That was an unexpected regression for applications switching from libidn2 and thus it is no longer applied by default. Use IDN2\_USE\_STD3\_ASCII\_RULES to enable that behavior again.

  On error, returns undef. If a scalar variable is provided in *$rc*,  returns the internal libidn2 C library result code as well.

- **Net::LibIDN2::idn2\_lookup\_ul**(*$src*, \[*$flags*, \[*$rc*\]\]);

  Alternative name idn2\_to\_ascii\_l.

  Similar to function `"idn2_lookup_u8"` but *$src* is assumed to be encoded in  the locale's default coding system, and will be transcoded to UTF-8 and NFC  normalized before returning the result.

- **Net::LibIDN2::idn2\_register\_u8**(*$ulabel*, \[*$alabel*, \[*$flags*, \[*$rc*\]\]\]);

  Perform IDNA2008 register string conversion on domain label *$ulabel* and *$alabel*, as described in section 4 of RFC 5891. Note that the input ulabel must be encoded  in UTF-8 and be in Unicode NFC form.

  Pass **IDN2\_NFC\_INPUT** in *$flags* to convert input *$ulabel* to NFC form before further processing.

  It is recommended to supply both *$ulabel* and *$alabel* for better error checking, but supplying just one of them will work. Passing in only *$alabel* is better than only *$ulabel*. See RFC 5891 section 4 for more information.

  On error, returns undef. If a scalar variable is provided in *$rc*,  returns the internal libidn2 C library result code as well.

- **Net::LibIDN2::idn2\_register\_ul**(*$ulabel*, \[*$alabel*, \[*$flags*, \[*$rc*\]\]\]);

  Similar to function `"idn2_register_u8"` but *$ulabel* is assumed to be encoded in  the locale's default coding system, and will be transcoded to UTF-8 and NFC  normalized before returning the result.

- **Net::LibIDN2::idn2\_to\_unicode\_88**(*$input*, \[*$flags*, \[*$rc*\]\]);

  Converts a possibly ACE encoded domain name in UTF-8 format into a an UTF-8 encoded string (punycode decoding).

  On error, returns undef. If a scalar variable is provided in *$rc*,  returns the internal libidn2 C library result code as well.

- **Net::LibIDN2::idn2\_to\_unicode\_8l**(*$input*, \[*$flags*, \[*$rc*\]\]);

  Similar to function `"idn2_to_unicode_88"` but the return value is encoded in  the locale's default coding system.

- **Net::LibIDN2::idn2\_to\_unicode\_ll**(*$input*, \[*$flags*, \[*$rc*\]\]);

  Similar to function `"idn2_to_unicode_8l"` but *$input* is also assumed to be encoded in  the locale's default coding system.

- **Net::LibIDN2::idn2\_strerror**(*$rc*);

  Convert internal libidn2 error code *$rc* to a human-readable string.

- **Net::LibIDN2::idn2\_strerror\_name**(*$rc*);

  Convert internal libidn2 error code *$rc* to a string corresponding to internal header file symbols names like IDN2\_MALLOC.

- **Net::LibIDN2::idn2\_check\_version**(\[*$req\_version*\])

  Checks that the version of the underlying IDN2 C library is at minimum the one given as a string in *$req\_version* and if that is the case returns the actual version string  of the underlying C library or undef if the condition is not met. If no parameter is passed to this function no check is done and only the version  string is returned.

  See **IDN2\_VERSION** for a suitable *$req\_version* string, it corresponds to  the idn2.h C header file version at compile time of this Perl module. Normally these two version numbers match, but if you compiled this Perl module against an older libidn2  and then run it with a newer libidn2 shared library, they will be different.

### Constants

- **IDN2\_VERSION**

  Pre-processor symbol with a string that describes the C header file version number at compile time of this Perl module. Used together with **idn2\_check\_version()** to verify header file and run-time library consistency.

- **IDN2\_VERSION\_NUMBER**

  Pre-processor symbol with a hexadecimal value describing the C header file version number at compile time of this Perl module. For example, when the header  version is 1.2.4711 this symbol will have the value 0x01021267. The last four digits are used to enumerate development snapshots, but for all public releases they will be 0000.

- **IDN2\_VERSION\_MAJOR**

  Pre-processor symbol for the major version number (decimal). The version scheme is major.minor.patchlevel.

- **IDN2\_VERSION\_MINOR**

  Pre-processor symbol for the minor version number (decimal). The version scheme is major.minor.patchlevel.

- **IDN2\_VERSION\_PATCH**

  Pre-processor symbol for the patch level number (decimal). The version scheme is major.minor.patchlevel.

- **IDN2\_LABEL\_MAX\_LENGTH**

  Constant specifying the maximum length of a DNS label to 63 characters, as specified in RFC 1034.

- **IDN2\_DOMAIN\_MAX\_LENGTH**

  Constant specifying the maximum size of the wire encoding of a DNS domain to 255 characters, as specified in RFC 1034. Note that the usual printed representation of a domain name is limited to 253 characters if it does not end with a period or 254 characters if it ends with a period.

### Result codes

- **"Net::LibIDN2::IDN2\_OK"** Successful return.

  - **"Net::LibIDN2::IDN2\_MALLOC"** Memory allocation error.

  - **"Net::LibIDN2::IDN2\_NO\_CODESET"** Could not determine locale string encoding format.

  - **"Net::LibIDN2::IDN2\_ICONV\_FAIL"** Could not transcode locale string to UTF-8.

  - **"Net::LibIDN2::IDN2\_ENCODING\_ERROR"** Unicode data encoding error.

  - **"Net::LibIDN2::IDN2\_NFC"** Error normalizing string.

  - **"Net::LibIDN2::IDN2\_PUNYCODE\_BAD\_INPUT"** Punycode invalid input.

  - **"Net::LibIDN2::IDN2\_PUNYCODE\_BIG\_OUTPUT"** Punycode output buffer too small.

  - **"Net::LibIDN2::IDN2\_PUNYCODE\_OVERFLOW"** Punycode conversion would overflow.

  - **"Net::LibIDN2::IDN2\_TOO\_BIG\_DOMAIN"** Domain name longer than 255 characters.

  - **"Net::LibIDN2::IDN2\_TOO\_BIG\_LABEL"** Domain label longer than 63 characters.

  - **"Net::LibIDN2::IDN2\_INVALID\_ALABEL"** Input A-label is not valid.

  - **"Net::LibIDN2::IDN2\_UALABEL\_MISMATCH"** Input A-label and U-label does not match.

  - **"Net::LibIDN2::IDN2\_NOT\_NFC"** String is not NFC.

  - **"Net::LibIDN2::IDN2\_2HYPHEN"** String has forbidden two hyphens.

  - **"Net::LibIDN2::IDN2\_HYPHEN\_STARTEND"** String has forbidden starting/ending hyphen.

  - **"Net::LibIDN2::IDN2\_LEADING\_COMBINING"** String has forbidden leading combining character.

  - **"Net::LibIDN2::IDN2\_DISALLOWED"** String has disallowed character.

  - **"Net::LibIDN2::IDN2\_CONTEXTJ"** String has forbidden context-j character.

  - **"Net::LibIDN2::IDN2\_CONTEXTJ\_NO\_RULE"** String has context-j character with no rule.

  - **"Net::LibIDN2::IDN2\_CONTEXTO"** String has forbidden context-o character.

  - **"Net::LibIDN2::IDN2\_CONTEXTO\_NO\_RULE"** String has context-o character with no rule.

  - **"Net::LibIDN2::IDN2\_UNASSIGNED"** String has forbidden unassigned character.

  - **"Net::LibIDN2::IDN2\_BIDI"** String has forbidden bi-directional properties.

  - **"Net::LibIDN2::IDN2\_DOT\_IN\_LABEL"** Label has forbidden dot (TR46).

  - **"Net::LibIDN2::IDN2\_INVALID\_TRANSITIONAL"** Label has character forbidden in transitional mode (TR46).

  - **"Net::LibIDN2::IDN2\_INVALID\_NONTRANSITIONAL"** Label has character forbidden in non-transitional mode (TR46).

  ## AUTHOR

Thomas Jacob, https://github.com/gnuthor

## SEE ALSO

[**perl**(1)](/perl/1.md), RFC 5890-5893, TR 46, https://gitlab.com/libidn/libidn2.
