---
name: "Net::FTPServer::RO::Server"
section: "3pm"
platform: "linux"
package: "libnet-ftpserver-perl"
version: "1.120-1"
release: "Debian 3.1 (Sarge)"
platforms: ["linux"]
url: "https://new.carta.tech/Net::FTPServer::RO::Server"
---

# Net::FTPServer::RO::Server(3pm)

The anonymous read-only FTP server personality

## NAME

Net::FTPServer::RO::Server - The anonymous read-only FTP server personality

## SYNOPSIS

```
  ftpd [-d] [-v] [-p port] [-s] [-S] [-V] [-C conf_file]
```

## DESCRIPTION

`"Net::FTPServer::RO::Server"` is the anonymous read-only FTP server personality. This personality implements a complete FTP server with similar functionality to *wu-ftpd*, except that it is not possible to write and all logins must be anonymous.

## METHODS

- $rv = $self-\>authentication\_hook ($user, `$pass`, `$user_is_anon)`

  Perform login against `"/etc/passwd"` or the PAM database.

- $self-\>user\_login\_hook ($user, $user\_is\_anon)

  Hook: Called just after user `$user` has successfully logged in.

- $dirh = $self-\>root\_directory\_hook;

  Hook: Return an instance of Net::FTPServer::RO::DirHandle corresponding to the root directory.

## FILES

```
  /etc/ftpd.conf
  /usr/lib/perl5/site_perl/5.005/Net/FTPServer.pm
  /usr/lib/perl5/site_perl/5.005/Net/FTPServer/DirHandle.pm
  /usr/lib/perl5/site_perl/5.005/Net/FTPServer/FileHandle.pm
  /usr/lib/perl5/site_perl/5.005/Net/FTPServer/Handle.pm
  /usr/lib/perl5/site_perl/5.005/Net/FTPServer/RO/Server.pm
  /usr/lib/perl5/site_perl/5.005/Net/FTPServer/RO/DirHandle.pm
  /usr/lib/perl5/site_perl/5.005/Net/FTPServer/RO/FileHandle.pm
```

## AUTHORS

Richard Jones (rich@annexia.org).

## COPYRIGHT

Copyright (C) 2000 Biblio@Tech Ltd., Unit 2-3, 50 Carnwath Road, London, SW6 3EG, UK

## SEE ALSO

*Net::FTPServer*(3), *Net::FTP*(3), [*perl*(1)](/perl/1.md), RFC 765, RFC 959, RFC 1579, RFC 2389, RFC 2428, RFC 2577, RFC 2640, Extensions to FTP Internet Draft draft-ietf-ftpext-mlst-NN.txt.
