---
name: "Net::FTPServer::Full::Server"
section: "3pm"
platform: "linux"
package: "libnet-ftpserver-perl"
version: "1.120-1"
release: "Debian 3.1 (Sarge)"
platforms: ["linux"]
url: "https://new.carta.tech/Net::FTPServer::Full::Server"
---

# Net::FTPServer::Full::Server(3pm)

The full FTP server personality

## NAME

Net::FTPServer::Full::Server - The full FTP server personality

## SYNOPSIS

```
  ftpd [-d] [-v] [-p port] [-s] [-S] [-V] [-C conf_file]
```

## DESCRIPTION

`"Net::FTPServer::Full::Server"` is the full FTP server personality. This personality implements a complete FTP server with similar functionality to *wu-ftpd*.

## METHODS

- $rv = $self-\>authentication\_hook ($user, `$pass`, `$user_is_anon)`

  Perform login against `"/etc/passwd"`, the PAM database or the `"password file"`.

- $self-\>user\_login\_hook ($user, $user\_is\_anon)

  Hook: Called just after user `$user` has successfully logged in.

- $dirh = $self-\>root\_directory\_hook;

  Hook: Return an instance of Net::FTPServer::FullDirHandle corresponding to the root directory.

## FILES

```
  /etc/ftpd.conf
  /usr/lib/perl5/site_perl/5.005/Net/FTPServer.pm
  /usr/lib/perl5/site_perl/5.005/Net/FTPServer/DirHandle.pm
  /usr/lib/perl5/site_perl/5.005/Net/FTPServer/FileHandle.pm
  /usr/lib/perl5/site_perl/5.005/Net/FTPServer/Handle.pm
  /usr/lib/perl5/site_perl/5.005/Net/FTPServer/Full/Server.pm
  /usr/lib/perl5/site_perl/5.005/Net/FTPServer/Full/DirHandle.pm
  /usr/lib/perl5/site_perl/5.005/Net/FTPServer/Full/FileHandle.pm
```

## AUTHORS

Richard Jones (rich@annexia.org).

## COPYRIGHT

Copyright (C) 2000 Biblio@Tech Ltd., Unit 2-3, 50 Carnwath Road, London, SW6 3EG, UK

## SEE ALSO

*Net::FTPServer*(3), *Authen::PAM*(3), *Net::FTP*(3), [*perl*(1)](/perl/1.md), RFC 765, RFC 959, RFC 1579, RFC 2389, RFC 2428, RFC 2577, RFC 2640, Extensions to FTP Internet Draft draft-ietf-ftpext-mlst-NN.txt.
