NAME
MIME::EncWords::JA_JP - RFC 2047 encoded-word XX (XXX)
SYNOPSIS
MIME::EncWords XXRFC 2047 (X RFC 1522) XXXXXXXXXXXXXXXXX MIME::Words XXXXXXX XXXXXXXXXXXXXXXXXXXX XXXXXXXXXXXXX MIME::Words XXXXXXXXX XXXXXX (**) XXXXXXXXXXXXX (*) XXXXXXXXX
XXXXXXXXMIME::Tools XXXXXXXXXXXX XXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXX XXXXXXXX XXXXXXXXXXXX
XXXXXXXXXX...
use MIME::EncWords qw(:all);### XXXXXXXXXXXXXXXXXXXXXXXXXXXXXX:$decoded = decode_mimewords('To: =?ISO-8859-1?Q?Keld_J=F8rn_Simonsen?= <[email protected]>',);### XXXXXXXXXXXX [DATA,CHARSET] XXXXXXXX:@decoded = decode_mimewords('To: =?ISO-8859-1?Q?Keld_J=F8rn_Simonsen?= <[email protected]>',);### XXXXXXXXXXXXXXXXXXX:$encoded = encode_mimeword("\xABFran\xE7ois\xBB");### XXXXXXXXXXXXXXXXXXXXXXXXXX:$encoded = encode_mimewords("Me and \xABFran\xE7ois\xBB in town");
DESCRIPTION
XXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXX XXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXX"(:-)"X
XXXXXXXXXXX MIME XXXX:
From: =?US-ASCII?Q?Keith_Moore?= <[email protected]>To: =?ISO-8859-1?Q?Keld_J=F8rn_Simonsen?= <[email protected]>CC: =?ISO-8859-1?Q?Andr=E9_?= Pirard <[email protected]>Subject: =?ISO-8859-1?B?SWYgeW91IGNhbiByZWFkIHRoaXMgeW8=?==?ISO-8859-2?B?dSB1bmRlcnN0YW5kIHRoZSBleGFtcGxlLg==?==?US-ASCII?Q?.._cool!?=
XXXXXXXXXXXXXXXXXXXXXXXXXXXX:
From: Keith Moore <[email protected]>To: Keld Jorn Simonsen <[email protected]>CC: Andre Pirard <[email protected]>Subject: If you can read this you understand the example... cool!
XX: XXXXXXXXXX XXXXXXXXXXXXXXXXXXXXXXXXXX XXXXXXXXXXXXXXXXXXXXXXXXXXXXXXX "(^_^)".
XXXXXXXXXXX MIME XXXX:
Subject: =?EUC-KR?B?sNTAuLinKGxhemluZXNzKSwgwvzB9ri7seIoaW1w?==?EUC-KR?B?YXRpZW5jZSksILGzuLgoaHVicmlzKQ==?=
XXXXXXXXXXXXXXXXXXXXXXXXXXXX:
Subject: XXX(laziness), XXXX(impatience), XX(hubris)
PUBLIC INTERFACE
- decode_mimewords ENCODED, [OPTS...]
-
XXX XXXXX RFC 2047 XXXXX "Q" XXXXXXXX (quoted-printable XXX) X "B" XXXXXXXX (base64) XXXXXXXXXXXXXX
XXXXXXXXXXXXXX ENCODED XXXXXXX
"[DATA, CHARSET]"XXXXXXXXXXXXXXXX XXXXXXXXXXXXXXXXX 1 XXXXX"[DATA]"XXX (CHARSET XXXXX"undef")X$enc = '=?ISO-8859-1?Q?Keld_J=F8rn_Simonsen?= <[email protected]>';foreach (decode_mimewords($enc)) {print "", ($_[1] || 'US-ASCII'), ": ", $_[0], "\n";}** XXXXXXXXXencoded-wordXXXXXXXXXXXXXXXXXXXXXX XXXXXXXXXXXXXXXXXXXXXXXXXXXXX
** RFC2231 X 5 XXXXXXXXXXXXXXXXXX 3 XXXXXXXXXXX
* XXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXX XXXXMIME::Words XXXXXXXXXXXXXX
XXXXXXXXXXXXXXXXXXX DATA XXXXXXXXXX XXXXXXXX: XXXXXXXXXXX XXXXXXXXXXXXXXXXXX XXXXXX ENCODED XXXXXXXXXXXXXXXXXXXXXXXXXXXXXXX XXXXXXXXXXXXX (XXXXXXXX"unmime" in MIME::WordDecoder XXXXXXX XXXXXXXXXXXXXXX) ** XXX "Charset" XXXX
XXXXXXXXXXXX$@ XXXXXXXXXXXXXXX XXXXXXXXX (XXXXXXXXXXXXXXXXXXXXXX) XXXXX XXXXXXXXXXXXX$@ XXXXXX
* Xencoded-wordXXXXXXXXXXXXXXXXXXXXXXXXXXX XXXXX$@ XXXXXXX
ENCODED XXXXXXXXXXXXXXXXXXXXXXXXXXXXX ** Unicode/XXXXXXXXXXXXXXXXXXXXXX ("USE_ENCODE" in MIME::Charset::JA_JP XX) XX XXXXXXXXXXXXXXXXXXXX
- Charset **
-
XXXXXXXXXXXDATA XXXXXXXXXXXXXXXXXXXXXX XXXXXXXXXXX
"_UNICODE_"XXXXXXX XXXX Unicode XXXXXXXNote: XXXXXX"_UNICODE_" XXXXXXXXXXX XXXXXXXXXXXX
- Detect7bit **
-
XXXXXXXXXXXXXXXX 7 XXXXXXXXXXXXXXXXXXXXX XXXX
"YES"X
- Mapping **
-
XXXXXXXXXXX XXXXXXXXXXXXXXXXXXXXXXXXXXXXXXX
"EXTENDED"XXXXXXXXXXXX"STANDARD"XXXXXXXXXXXXXXXXXXXXX XXXX"EXTENDED"X
- encode_mimeword RAW, [ENCODING], [CHARSET]
-
XXX XXXXXXXXXXXXXXXXXXRAW XXXXXXXXX XXXXXXXXXXXXXXX
### "XFrancoisX" XXXXXXXX:$encoded = encode_mimeword("\xABFran\xE7ois\xBB");XXXXXXXX ENCODING XXXXXX (
"Q"XXX"B")X XXXX"Q"X ** XXXXXXXXXXXXXXXXX"S"X"Q"X"B"XXXXXXXXXXXXXXXXXXXXX CHARSET XXXXXXXXXXX
"iso-8859-1"X*
"Q"XXXXXXXXXXXXXX ``_'' XXXXXXXXX
- encode_mimewords RAW, [OPTS]
-
XXX XXX RAW XXXXXXXXXXXXXXXXXXXXXXXXXXXXXXX
### XXXXXXXXXXXXXXXXXXXXXX:$encoded = encode_mimewords("Me and \xABFran\xE7ois\xBB");XXXXXXXXXXXXXX
** RAW X Unicode XXXXXXXX Unicode/XXXXXXXXXXXXXX ("USE_ENCODE" in MIME::Charset::JA_JP XX)X XXX RAW XX"decode_mimewords" XXXXXXXXXXXXXXXXXXXXXXX XXXXXX"Charset" XXXXX (XXXX) XXXXXXXXX (XXXXXX)X
Note: * RAW XXXXXXXXXXXXXX XXXXXencoded-wordX (XXXXASCII XXXXXXXXXXXXXXXXXX) XXXXXXXXXXXXXXXXXXXXXXXXXXXXXXX (XXXXXX Unicode/XXXXXXXXXXXXXXXX)XXXXXX XXXXXXXXXXXXXXXXXXXXXXXXX XXXXXXXXXXXXencoded-wordXXXXXXXXXXX
RAW XXXXXXXXXXXXXXXXXXXXXXXXXXXX:
- Charset
-
XXXXXXXXXXXXXXXXXXXXXXXXXXXXX XXXX 'ISO-8859-1' (XX "Latin-1")X
- Detect7bit **
-
"Encoding" XXXXX (XXXX) X
"a"XXXXXXXX "Charset" XXXXXXXXXXX RAW XXXX 7 XXXXXXXXXXXXXXXXXXXXX XXXX"YES"X Unicode/XXXXXXXXXXXXXXXXXXXXXX ("USE_ENCODE" in MIME::Charset::JA_JP XX) XX XXXXXXXXXXXXXXXXXXX
- Encoding
-
XXXXXXXXXXXXX
"q"XXX"b"X ** XXXXXXXXXXXXX"a"XXXXXXXXXXXXXXXXXXXXX (XXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXX MIME::Charset::JA_JP XX)X"s"X"q"X"b"XXXXXXXXXXXXX Note: * XXXX 1.005 XXXXXX"q"(MIME::Words XXXXX) XX"a"XXXXXX
- Field
-
XXXXXXXXXXXXXXXXXXXX ** XXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXX
- Folding **
-
XXXXXXXXXXXXXXXXXXXXXXXXX
"\n"X XXXX""XXXXXXXXX (XX "MaxLineLen" XX) XXXXXencoded-wordXX SPACE XXXXXXXXNote: * RFC 5822 (X RFC 2822) XXXXXXXXXXXXXXXXXXXX CRLF (
"\r\n") XXXXXXXXXXXXX XXXXXXXXXXXXXXXXXXXX LF ("\n") XXXXXXXXXX XXXXXXXXXXXX XXXXXXXXXXXXXXXXXXXXXXX XXXXXXXXXXXXXXXXXXX
- Mapping **
-
XXXXXXXXXXXXXXXXXXXXXXXXXXXXXXX
"EXTENDED"XXXXXXXXXXXX"STANDARD"XXXXXXXXXXXXXXXXXXXXX XXXX"EXTENDED"X Unicode/XXXXXXXXXXXXXXXXXXXXXX ("USE_ENCODE" in MIME::Charset::JA_JP XX) XX XXXXXXXXXXXXXXXXXXX
- MaxLineLen **
-
XXXXX (XXXXX)X XXXX 76X XXXXXXXXXXXXXX (XXXX 1.012.3 XX)X
- Minimal **
-
XXXXXXXXXXXXXXXXXXXXX (XXXXXXXX) XXXXXXX
"NO"XXXXXXX XXXXXXXXXXXXXXXXXXXXXXXXXXXXXX (XXXXXXXXXX) XXXXXXXXXencoded-wordXXXXXXXXXXXXXXXXXX XXXX"YES"XXXXXXXXXXXXXXXXXX"DISPNAME"XXXXXXXRFC5322 (X RFC2822XRFC822) XXXXXXX (3.4X) XXXXXXXXXXXXXXXXXXXXXXXX XXXXXXXXXXXXXX display-name XXXXXXXXXXXXXXXXNote: XXXX 0.040 XXXXXX
"YES"XXXXXX MIME::Words XXXXXXXXXXXXXX XXXXXXXXXXXXXXXXXXXX"NO"XXXXXXXNote:
"DISPNAME"XXXXX 1.012 XXXXXXX
- Replacement **
-
"XXXXX" in MIME::Charset::JA_JP XXX
XXXXXX **
"decode_mimewords" ('Charset' XXXXXXXX) XXX "encode_mimewords" XXXXXXXXXXXXXXXXXX XXXXXXXXXXXXXX MIME/Charset/Defaults.pm X MIME/EncWords/Defaults.pmX XXX MIME/EncWords/Defaults.pm.sample XXXXXXXX
VERSION
$VERSION XXXXXXXXXXX
XXXXXXXXXXXX http://hatuka.nezumi.nu/repos/MIME-EncWords/ <http://hatuka.nezumi.nu/repos/MIME-EncWords/> XXXX
SEE ALSO
MIME::Charset::JA_JP, MIME::Tools
AUTHORS
decode_mimewords() XXXXXXX MIME::Words XXXXXXXXXXXXXXXXXXXXXXXXX:
Eryq ([email protected]), ZeeGee Software Inc (http://www.zeegee.com).
David F. Skoll ([email protected]) http://www.roaringpenguin.com
XXXXXXXXXXXXXXXXXXXXXXXX:
Hatuka*nezumi - IKEDA Soji <hatuka(at)nezumi.nu>.
This program is free software; you can redistribute it and/or modify it under the same terms as Perl itself.